konvenientSUSE

KonvenientSUSE je prográmek, který můžete [?:http://kde-apps.org/content/download.php?content=43378&id=1 stáhnout] pro openSUSE 10.2 a on za vás vyřeší několik problémů.

K samotné instalaci budete potřebovat stažený program konvenientSUSE a kommander-runtime, který najdete na instalačním DVD. Po instalaci se vytvoří zástupce v Aplikacích - Systém - Nastavení služeb - Setup openSUSE conveniently. Též ho můžete spustit pomocí příkazu konvenientsuse.

Po zadání hesla roota se již představí program sám. Obsahuje tři důležité záložky vztahující se k třem správcům balíčků. ZENWorks, openSUSE a Smart. První, co udělejte je přechod ze ZENWorks na openSUSE. Jděte na záložku openSUSE a v Introduction stiskněte tlačítko Kick Zmd. Důvod je prostý většina uživatelů není v síťi, které jsou kontrolované pomocí ZENworks a tak jej nepotřebují. Nehledě na to, že zmd vyžaduje mnoho systémových zdrojů. Kick Zmd za vás provede příkaz na odinstalování zmd, zen-updater, libzypp-zmd-backend a rug a nahradí jej openSUSE updaterem.

Tím se pro nás stávají podstatné už jen karty openSUSE a Smart, záleží na vás, který správce balíčků budete preferovat. Pro oba jsou dostupné záložky se zdroji balíčků a tak stačí jednoduché kliknutí a zdroj bude přidán.

Uživatelé, kteří mají grafickou kartu GeForce3 nebo vyšší si navíc mohou aktivovat 3D akceleraci.

Poslední věcí, kterou konvenientSUSE umí, je aktivace XGL a Compiz, které jsou defaultně nainstalovány. K dispozici je též zdroj pro instalaci Berylu.

konvenientSUSE je tedy přítulný program, který dokáže během pár minut vyřešit většinu problémů s čerstvou instalací openSUSE 10.2

Komentáře

Creator odpověděl -

Snad nebudou s programem samotnym podobne problemy, jako s delanim tech veci rucne. 10.2 jeste nemam, takze to nevyzkousim, ale zni to opravdu slibne.

Neznámý odpověděl -

Co se tyce ZENWorks, tech se lze zbavit pouhou odinstalaci odpovidajicich baliku pomoci Yastu. Kupodivu se mne pote v panelu ihned objevil OpenSUSE updater :-)

JirkaZ odpověděl -

že homepage programu i s nějakými screenshoty je zde.

Laco odpověděl -

No neviem ako vam, ale mne to neide nainstalovat a zlyhava to na zavislostiach...

kommander-runtime-3.5.5-29.i586[20070205-202350] needed by konvenientsuse-10.2.3-3.noarch[Local packages]

Takze tak...

JirkaZ odpověděl -

Laco, co tu onehdy strašně nadával na SUSE nebo Linux obecně?

Umíte číst? Pokud jo, přečtěte si hned první větu ve druhém odstavci v textu od pana Větvičky...

Petr7 odpověděl -

Jasně, že to je on a jeho šprýmy o "vyladěných" XP. Není třeba se mu smát, ne každý vychodil devět let základky a umí přečíst všechna písmenka.

Wizi odpověděl -

Bohužel konvenientsuse nefunguje pod GNOME... škoda.

vladano odpověděl -

error

Let's talk about s.x - Suse linuX ;o)

tomas_m odpověděl -

vybornej soft..sice mam uz vsechny ty veci rozjety,ale pro zacatecniky nebo novou instalaci je to vynikajici vec!!jen bych doplnil ze mi to nejdriv hazelo nejakou chybu v cestach ze mi chybi soubor ktery tam,ale fyzicky byl...stacil restart a vse jede..

alvyn odpověděl -

Me to teda nějak nechce naběhnout. Po zadání root-hesla vyhodí hlášku:
Příkaz kmdr-executor /.../konvenientsuse.kmdr nenalezen.
Samozřejmš ten soubor v daném adresáři je.

Rosta odpověděl -

Tohle mi to taky hodilo. Chtelo to nejakou knihovnu libkommanderwidget.so.0, ale ta přímo najít a nainstalovat nešla. Našel jsem že je součástí kdewebdev3, ten jsem přidal a už to chodi (asi jsem přidal víc než tu knihovnu, ale ted jsem rad ze jsem to rozchodil :)

Neznámý odpověděl -

me to selhalo s touhle hlaskou
Unresolved dependencies:
Installing konvenientsuse-10.2.3-3.noarch[Local packages]
There are no installable providers of /usr/bin/konvenientsuse for konvenientsuse-10.2.3-3.noarch[Local packages]

co to znamena, neporadite nekdo ?

honzaS odpověděl -

Přečetl jste si pozorně článek, především jeho druhý odstavec? Asi ne, jinak by jste se neptal...

Neznámý odpověděl -

Precetl, ale nedal mi odpoved na mou otazku. Mozna pro vase doplneni, zrejme jste neco prehledl, neptam se na kommander-runtime, ten mam nainstalovany. V pripade ze by chybel, tak to napise hlasku jaka je popsana v jednom prispevku nize. Tak mate nejakou radu ?

tomas_m odpověděl -

instalujete to pres ZENworks??

Neznámý odpověděl -

Ano instaluju to pres zenworks

tomas_m odpověděl -

Zkuste to rozhodne pres SMART, kolega ma stejny problem a tez instaluje pres zenworks, ja to udelal SMARTem a vse ok..ve SMARTu vsechny soucasti konvenientu odinstalujte a pak znovu nainstalujte treba bude vysledek jiny..a spravny :)

Neznámý odpověděl -

diky, s rpm to klaplo a funguje. musim rict, ze jsem rad ze jsem se toho zenworks zbavil.

pikec odpověděl -

Tak jsem si ušetřil spoustu času, no ale zase jsem se něco přiučil. Jinak jsem to musel instalovat taky příkazem: rpm -Uvh "balíček". A taky jsem díky tomu sprovoznil (klik, restart a jeto) to XGL, které bylo nějak nad moje síly sprovoznit jinou cestou. Díky!
Takže je to taková pro mě vychytávka s prací na ploše, ale nevím přesně všechny funkce. A další mám stařičkou grafiku ati 7000 agp 4x a je to pro ní docela záhul. Když to mám spuštěné, tak třeba dvd obraz jede jakoby spomaleně. Ale je to pěkná hračka, na kterou si rychle zvyknu.

Začal jsem si hrát se SUSE a SLAX a úplně mě pohltili.

pikec odpověděl -

Tak jak jsem psal mě to šlape a píšu postup, který mám ještě v hlavě před chvilkou jsem to dával do nové instalace. Podle návodu co je zde instaluji balíček "kommander-runtime" přes Yast. Pak stáhnu "konvenientSUSE" zde uvedeným odkazem a uložím ho do složky "tmp". Vše jsem dělal v Kde. A teď pomocí "Ctrl+Alt+F1 přejdu do textového režimu, kde se přihlásím jako uživatel + heslo pak jako root(příkaz su) + heslo. najdu cestu kde ho mám uložený a to:
"cd /tmp" a pak příkaz "rpm -Uvh 43378-konvenientsuse-10.2.3-3.noarch.rpm" což je název toho balíčku a spustíme a hotovo. Tento návod mě šlapal dvakrát a bezproblémů.

Yarda odpověděl -

Jenom pro mě jako pro lamu, co linux vidí poprvé. Mohl by mi někdo říct, jak ten program funguje protože když kliknu třeba na tlačítko instal tak se nic neděje a mp3 mi mimo realplayer taky nejedou.

pikec odpověděl -

Jak instal a nic, v tom konvenientsuse? Když tam klikneš třeba na instal, tak pole zešedne a čekáš, až se zase vrátí do normálu nutné připojení k internetu a čekat a čekat, dle výkonu kompu a internetové rychlosti. Na celeronu 600 to byla věčnost z pohledu sempron 3000.

bady odpověděl -

Zdravim!
vsetko funguje, vsetko je super, je to super pekne, ALE ked si chcem pustit film tak mi to neak ide pomaly, akoby som mal slaby pocitac alebo tak... neda sa to neako nastavit? myslim ze by som si mohol vypat vsetky tie nadherne efekty, pozriet film a potom si ich zapat? lebo chcem beryl pouzivat, ale nechcem sa vzdat pozerania filmov, to budem musiet zakazdym vypnut xgl a restartnut pc ked si budem chciet pozriet neaky film?

pikec odpověděl -

Podle mě asi jo.

ra100 odpověděl -

nie si sam komu to robi.uz som to nahlasil do bugzilly.

proky.hb odpověděl -

zdravim,

po instalaci dostanu tuto hlasku

6328: Warning: unresolved direct binding for symbol '_ZN9KLineEdit17mouseReleaseEventEP11QMouseEvent' (error 0)
kmdr-executor: symbol lookup error: /opt/kde3/lib64/libkommanderwidgets.so.0: undefined symbol: _ZN9KLineEdit17mouseReleaseEventEP11QMouseEvent

vi nekdo co s tim? (pri posledni instalaci mi to fungovalo hned, jenze jsem trosku experimetoval a musel jsem cely system preinstalovat, stejny poc, stejna konfigurace, nechapu)